Framerate ein unlösbares Rätsel?

  • Ich möchte um Hilfe bitten, denn "normal" ist das sicher nicht:
    (Vorab: aktuelles WIN10 / DirechtX11 Version aktiviert / neusten Grafikarten Treiber)
    Egal was ich mache...mein PC hat um die 15 Frames und Ende..... und ja man kann damit fliegen aber es ist nicht schön und schon überhaupt nicht bei solch System was ich in mittelklasse einstufen könnte. Nun habe ich meine Einstellungen schgon auf die Schmerzgrenze runter-gesetzt aber immer noch 15 FRames..... ich kapier es wirklich nicht und deshalb einfach mal meine Einstellugen...eventuell findet Ihr den Fehler?
    Anzeigemodus: VollbildModus
    Auflösung im Vollbild Modus: 1920x1080
    Render Skalierung: 100
    DirectX Version: DX11
    Qualität Globales Rendering: Benutzerdefiniert
    Anti-Aliasing: TAA
    Grad der Detailgenauigkeit des Terrains: 160

    PRE-Caching für Terrain ausserhalb Schirm: Mittel
    Vector Datenmenge für Terrain: Mittel
    Gebäude: Hoch
    Bäume: Mittel
    Gras & Büsche: Mittel

    Grad detailgenaugkeit von Objekten: 150
    Volumetrische Wolken: Mittel
    Texturauflösung: Hoch
    Anistrophische Filterung: 8X
    Textur Super Sampling: 6x6
    TexturSynthese: Hoch
    Wasserauflösung: Hoch
    Shadow Mapping: 1024
    Terrainschatten: 256
    Kontaktschatten: Niedrig
    Windscheibeneffecte: Mittel
    Umgebungsverdeckung: Mittel
    Cube-Map-Refectionen: 96
    Raymarching Refelexionen: Mittel
    Lichtstrahlen: mittel

    Bloom: Ein

    Schärfentiefe: mittel
    Bewegungsunschärfe: Mittel
    Linsenkorrektur: AUS
    Blendenflecken: Aus
    Glascockpit Bildwiederholungsrate: mittel


    Jörg
    PC Version / WIN10 AMD7 /Ryzen 7 3700X 8-Core / 16GB Ram / NVidia Geforce RTX 2070 Super

  • auf was hast du unter Windows die Aktualisierungsrate in den erweiterten Anzeigeeinstellungen eingestellt?


    also nicht im Sim sondern im Windows unter Start / Einstellungen

    Liebe Grüße

    Alfons


    Prozessor: Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz 3.60 GHz

    Installierter RAM: 16,0 GB

    Grafikkarte: NVIDIA GeForce RTX 3060

    Laufwerke: SSD 1 TB, HDD 2 TB

    Internet: 500/25 Mbit

    BS: Windows 11 pro

    Thrustmaster TCA Sidestick Airbus Edition

  • Hallo,

    die 2070 super ist etwas fixer als meine 5700XT und der 3700X nicht viel langsamer (pro Kern) als mein 5800X. Also von der Hardware her sollte das passen. Ich hab hier 35-70FPS bei ähnlichen Einstellungen, aber bei 2560x1080.


    Vorab: Pre-Render außerhalb des Bildschirms: Ich kann da ULTRA empfehlen. Dann hast du beim umsehen weniger ruckler. Sonst rendert er nämlich erst beim umsehen. Aber soweit ist es ja noch nicht ;)

    Ideen dazu:

    • Kein FLS Limit im MSFS anwählen! Nur VSync off.
    • Im MSFS mal im Dev-.Mode die FPS anzeigen lassen. Der Mainthred sollte mindestens stabil gelb sein. Jeder rote Spike für zu einem sichtbaren FPS drop. Ich stell mich dazu bei NY auf den NewArk Platz auf das Rollfeld und stelle die Kiste wie erwähnt ein. Dann gibt es auch keine bis kaum Ruckler im Tiefflug über NY. Der Mainthread hängt halt an der CPU (weil ASOBO das olle DX11 nutzt, und das nicht mal gut, von DX12 wollen wir jetzt gat nicht anfangen).
      Die anderen Graphen sollten grün sein! Der Read-Thred kann im Tiefflug bei 300kn schon mal flickern...
    • Windows selber, also die Grafikeinstellungen dort, haben da eigentlich nichts mit zu tun.
    • Hast du noch einen onboard Grafikchip? Aber so wie sich die Hardware liest nicht. Ist ja auch kein Laptop...
    • Mal mit einem normalen Benchmark schauen ob es dort geht. Z.B. Unigine Heaven, der ist für DX11 (https://www.chip.de/downloads/Heaven-Benchmark-fuer-DirectX-11_38888066.html). Da mal sehen was der PC bringt.
    • Den Grafikkartentreiber sauber deinstallieren (Tool DDU: https://www.chip.de/downloads/Display-Driver-Uninstaller-DDU_65992840.html) und dann wieder installieren. Nicht das hier der von Windows genutzt wird.
    • Die anderen Treiber sind aber drauf? AMD Chipset etc?
    • Im Treiber oder einem Tool wie HW-Info schauen wie heiß die Karte wird. Nicht das es ein ThermalThrotteling ist wo sich die Karte selber schützt und runtertaktet. Da gibt es simple Lösungen für.
    • Warum eine BETA wie Win11 zum zocken?

    Viel Erfolg und Gruß Andre

    Gruß Andre/fussvolk (Heimathafen: EDLB)

  • Hast du Addons im Community Ordner? Wenn ja, teste als allererstes mal ohne, also mit leerem Ordner.

    Ist es dann immer noch so schlecht, aktiviere mal den Entwicklermodus und lasse dir dort die Performance anzeigen, da steht dann auch welcher Thread limitiert (GPU, CPU...)

    Als Intel-Jünger kann ich deine CPU nicht einschätzen, aber die Grafikkarte sollte bei deiner Auflösung locker in Ultra Settings 30 FPS halten können, vielleicht mit Einbrüchen auf größeren Flughäfen. Trotzdem solltest du auch mal auf Low oder Medium Einstellung Testen.

  • Danke für die ganzen Antworten...ich werde das heute Abend mal testen!
    Danke sagt Jörg

    Jörg
    PC Version / WIN10 AMD7 /Ryzen 7 3700X 8-Core / 16GB Ram / NVidia Geforce RTX 2070 Super

  • Danke für die ganzen Antworten...ich werde das heute Abend mal testen!
    Danke sagt Jörg

    Und schau dir auch mal im Task Manager an ob dich da irgend etwas runterzieht..

    Hast du was nebenbei laufen...im Hintergrund?

    Welche Verbindung hast du von Graka zu Monitor?

    Vielleicht da wo was defekt?

    Alles nur Vermutungen und Ferndiagnose..

    Jedenfalls meld dich wieder..egal obs funkt oder nicht..

    Denke das interessiert uns alle. 👍

    Lg. Reini

    (LOWS/LOWL)

  • Also Stand der Dinge:
    DDC runter geladen.
    Nach dem Start von DDC "verlangt" es, dass man im Abgesicherten Modus geht. (Um wohl besser deinstallieren zu können)
    Ich bin nicht in der Lage mit WIN10 in einen abgesicherten Modus zu kommen. Ich bezeichne es als Frechheit, wenn man beim Starten des PC genau für eine einzige Sekunde angezeigt bekommt "was-man-zu-drücken-hat" In meinem Fall war es Taste F11.
    Nun kommt ein Auswahlmenü.... mit 4 Möglichkeiten...alle 4 waren Blödsinn und funktionieren nicht.... Wer läßt sich so etwas einfallen?
    Entsetzte Grüße vom Jörg

    Jörg
    PC Version / WIN10 AMD7 /Ryzen 7 3700X 8-Core / 16GB Ram / NVidia Geforce RTX 2070 Super

  • Um wenigstens ansatzweise den vorhandenen Treiber zu entfernen bin ich bei Einstellungen zu der Seite APPs gegangen und dort runter gescrollt bis ich Nvidia Treiber gefunden habe, da dann auf Deinstallieren gegangen. PC wurde neu gestaret und erst jetzt habe ich den neuen Nvidia Treiber installiert.
    Jörg

    Jörg
    PC Version / WIN10 AMD7 /Ryzen 7 3700X 8-Core / 16GB Ram / NVidia Geforce RTX 2070 Super

  • Nun habe ich mal den Simulator gestartet "mit" Entwickler-Modus. Ich habe in EDDK (Vorfeld stehend) 28 FRames.
    ganz Oben steht (wo die Frames sind:
    29,8
    darunter 34,77 MS
    (beie blinken mehr rot als grün)
    Darunter:
    Limited by ManinThred PC D3D11
    Main Thred: 33,0 rotgelb rotgelb blinkend
    RdrThred: 13,8 grün dauerhaft
    Mainpulators: 19,9 gelb dauerhaft
    CoheretGTDraw: 0,5 grün dauerhaft
    GPU:12,5 grün dauerhaft
    im grauen Feld ganz unten steht:
    CPU Mem:5,994GB / 15,950 GB
    Peak CPU Mem: 6.310 GB
    GPU Mem: 2.402 GB/7,074GB

    Im Flugsimulator bei Optionen ist die "Limitierung" von 30 Frames ausgegraut und nicht bedienbar.....
    CPU Temperatur (mit Tool ausgelesen) = 63 Grad

    Nunhabe ich ein Flug erneut gestartet selbe Situation in Köln auf dem Vorfeld und nun sehen die Anzeigen im "Entwickler-Modus" wie folgt aus:

    (Vorfeld stehend) 28 FRames.

    ganz Oben steht (wo die Frames sind:

    36.9

    darunter 27,77 MS

    (beie grün und bei den FRames ist der Wellenbalken gelb))

    Darunter:

    Limited by ManinThred PC D3D11

    Main Thred: 26.9 gelbe wellen

    RdrThred: 5,0 grün dauerhaft

    Mainpulators: 16,0 grün dauerhaft

    CoheretGTDraw: 0,5 grün dauerhaft

    GPU:10,0 grün dauerhaft

    im grauen Feld ganz unten steht:

    CPU Mem:5,994GB / 15,950 GB

    Peak CPU Mem: 6.310 GB GPU Mem: 2.402 GB/7,074GB

    Bewege ich das Flugzeug "am Boden" auf Rollfeld:

    ganz Oben steht (wo die Frames sind:

    28.9

    darunter 34,5 MS

    (beie grün und mehr rot blinkend))

    Darunter:

    Limited by ManinThred PC D3D11

    Main Thred: 33,4 gelbe/rote wellen

    RdrThred: 15,0 grün dauerhaft

    Mainpulators: 16,0 grün dauerhaft

    CoheretGTDraw: 0,5 grün dauerhaft
    CoherentGTUI Thread:5.5

    GPU:12,5 grün dauerhaft

    im grauen Feld ganz unten steht:

    CPU Mem:5,994GB / 15,950 GB

    Peak CPU Mem: 6.310 GB

    GPU Mem: 2.402 GB/7,074GB


    In der Luft dann::

    ganz Oben steht (wo die Frames sind:

    38.9

    darunter 26,5 MS

    (beie gelbe wellen)

    Darunter:

    Limited by ManinThred PC D3D11

    Main Thred: 24,5 gelbe wellen

    RdrThred: 8,0 grün dauerhaft

    Mainpulators: 15,0 grün dauerhaft

    CoheretGTDraw: 0,5 grün dauerhaft

    CoherentGTUI Thread:9,9

    GPU:9,7 grün dauerhaft



    Ich hoffe Ihr könnt damit etwas anfangen?
    Einen schönen Tag wünscht Euch der Jörg

    Jörg
    PC Version / WIN10 AMD7 /Ryzen 7 3700X 8-Core / 16GB Ram / NVidia Geforce RTX 2070 Super

    3 Mal editiert, zuletzt von Stubenpilot ()

  • Moin,


    auf dem Feld 28 FPS klingt mit der Karte (je nach Einstellung) schon mal plausibel. Die GPU wird nicht ausgelastet weil der MSFS über den MainThread ausgelastet ist.


    Wenn du im MSFS nicht 30FPS anwählen kannst ist VSync nicht aktiv. Ohne VSYNC haut die Grafikengine ASAP raus = höhere FPS. Das muss aber nicht = stabileres bzw. weiche Bildfolge bedeuten. Freesync und G-Sync Monitore können ihre Bilddarstellung der Bildfolge der GPU anpassen, aber auch nur in einem begrenzten Bereich, z.B. 40-90 FPS. Außerhalb fängt es an zu ruckeln.


    Wenn du keinen Freesync oder G-Sync Monitor hast oder einfach VSYNC an ist bringt dir der 30FPS Lock folgendes: Die Bilder werden zwingend, aber mit stablen Zeitabständen mit 1/30 ausgegeben. Dein Monitor macht z.b. 1/60. Das deckt sich als Teiler und die Zeitabstände zwischen der Bilddarstellung sind gleichbleibend, das Bild wirkt ruhig und stabil (stabile Frametimes).
    Deshalb flackert es ja auch nicht bei TV/DVD/Blueray, obwohl die Teilweise bis auf 23,976 FPS runter gehen. Bilderzeugung und Bildwiedergabe sind im Takt, perfekt gleich bleibende Frametimes.


    GPU Temp. ist erst mal Top.


    Im Flug steigen die FPS und weil der Mainthread weniger drosselt, normal. Warum ist mir schleierhaft. Asobo könnte doch auf dem Boden die Sichtweite begrenzen. Warum Soll ich vom Rollfed auf dem Köln/Bonn schon den Dom sehen müssen ;)


    Der Mainthread ist die CPU Belastung die am Ende die Daten zur GPU liefert. Kann der Mainthred nicht mehr kann auch die GPU nichts machen. Meines wissens kann DX11 nur 4 Kerne ausnutzen, ein 12 Kerner bringt dir hier nix. DX12 könnte mehr aber Asobo muß auch die Software dafür anpassen. Aber die machen lieber "Worldupdates"

    Fazit:

    A) Senke die Slider für "Detailgenauigkeit des Terrains, z.B. 150" und "Detailgenauigkeit von Objekten z.B.100) " so weit ab das du auf dem Rollfeld den GPU Thread stabil mindestens gelb hast, ohne rote Spikes. Dann wird es selbst im Tiefflug nur kurz mal ruckeln. Je mehr du die Einstellungen so anpasst das der Mainthread auf dem Boden auch grün wird = nie wieder ruckeln im Flug.


    B) Übertakte deine CPU, das bringt mehr Power für den Mainthread. Der MSFS hängt stark an der CPU Kernpower, nicht anzahl der Kerne. Aber das ist nur mit DX11 gültig.


    C) Warte auf eine ordentliche Software seitens Asobo/Microsoft.


    Ich wünsche geholfen zu haben.

    Gruß Andre/fussvolk (Heimathafen: EDLB)

  • Ich stimme Andre fast komplett zu.

    Bis auf die empfohlene Übertaktung! Denn da reagiert der FS, soweit ich das bisher gelesen habe, gerne mal allergisch drauf.

    Und ja, am Boden, vor allem auf größeren Flughäfen, geht die Performance bei mir auch oft etwas runter. Dabei empfinde ich 28fps noch eher als unauffällig, aber teilweise geht es auch auf 25 oder noch etwas tiefer und das ruckelt dann schon störend. Da das aber nur beim Rollen im Bereich der Gates so stark auftritt, ist mir das egal und ich sehe keinen Bedarf die Grafik deswegen runterzuschrauben.

    Wenn dein Monitor auf mehr wie 60fps läuft, musst du die Begrenzung entsprechend umrechnen. Oder, so mache ich es auch: Im Grafiktreiber eine Begrenzung festlegen.

  • Hallo, danke. Aber deshalb ja auch stabil übertakten. Ich kann hier beim Fliegen noch mit Handbrake Videos kodieren. Aber das ist auch nicht jedermans Sache, ich habe es auch lange Zeit nicht gemacht.


    Im Anhang ein PDF wo ich mir gerade mal die Zusammenhänge von Mainthread/FPS und Frametimes im MSFS angesehen habe. Vielleicht hilft es weiter...

    Dateien

    Gruß Andre/fussvolk (Heimathafen: EDLB)

  • Hallo liebe Flugfreunde
    Habe mir all-die-Hinweise rein-gezogen und fast Alles umgesetzt. Ich habe nun komplet stabile 31 bis 29 Frames.... habe VSync oder wie das heißt wieder aktiviert...erstklassige Grafik... kein Ruckeln mehr...NIX.
    Mit dem Übertakten...ja habe oft davon gelesen, habe auch das entsprechende Tool dazu...aber ich verstehe rein NIX davon was die da vor-schlagen oder empfehlen..... zu Mal die Option fehlt dass man falls Alles schief geht...man in den original Zustand "zurück" kehren kann...ich lasse die Finger davon...30 Frames sind mehr als ausreichend!
    Und deshalb habt 100000 Dank für die Hinweise...... ich bin nun glücklich und zu frieden.
    nette Grüße vom Jörg

    Jörg
    PC Version / WIN10 AMD7 /Ryzen 7 3700X 8-Core / 16GB Ram / NVidia Geforce RTX 2070 Super

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!